Changes in Theme not reflecting in mobile only on Desktop

I changed HTML, PHP code of foodica to remove entry-meta details (Author, Date, Category) from slider. It shows perfectly in the Desktop site but still showing in the mobile site. Any clue?

I just removed the part of entry-meta where it was showing these details.

Probably your website is cached, and on mobile version you see an old cached version.

Try to clear the cache on your website:

Hi Pavel, Thanks for your reply. I tried the suggestions mentioned in the link you shared. Purged all the caches. Doesn’t seems like a cache issue.
Is there some specific code in the theme that might hinder changes getting propagated to the mobile version?
You can checkout my website at, if that helps
This is my wpzoom-slider.php code. I have removed entry-meta info then also it’s showing on mobile. Similarly, other changes done on the theme only visible in Desktop not mobile.

<?php // Get our Featured Content posts $slider = foodica_get_featured_content(); // If we have no posts, our work is done here if ( empty( $slider ) ) return; ?>
<ul class="slides clearfix">

	<?php foreach ( $slider as $post ) : setup_postdata( $post ); ?>


        $large_image_url = wp_get_attachment_image_src( get_post_thumbnail_id(), 'foodica-loop-sticky');

        $style = ' style="background-image:url(\'' . $large_image_url[0] . '\')"';


        <li class="slide">

            <div class="slide-overlay">

                <div class="slide-header">

                    <?php the_title( sprintf( '<h3><a href="%s">', esc_url( get_permalink() ) ), '</a></h3>' ); ?>

                    <div class="slide_button">
                        <?php /* translators: %s: link to the post */ ?>
                        <a href="<?php the_permalink(); ?>" title="<?php printf( esc_attr__( 'Permalink to %s', 'foodica' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark"><?php esc_html_e('Read More', 'foodica'); ?></a>



            <div class="slide-background" <?php echo $style; ?>>
    <?php endforeach; ?>

<?php wp_reset_postdata(); ?>

@foodaholick Hi,

I just checked your website on my mobile devices, and there is no date included in the slider:

Hi Pavel
I don’t know how that is working for you. I even asked few of my friends to send screen shots of the home page, I see the date & categories etc on all of them. I tried android, iphone same problem with every phone.
Which phone are you using? Could it be related to screen size?
I don’t understand what is happening :frowning:

On my computer there is also no date, so I don’t think it matters what device I use:

I realized issue is specific to chrome mobile browser. On other mobile browsers site loads fine. But for chrome even on new devices it shows old data. Any idea what could be the reason? I have tried clearing w3 plugin cache as well as bluehost server cache. Nothing seems to be working.

Also, I checked in multiple countries for chrome browser. Still no luck

I reinstalled the theme to make sure I didn’t break it. Still any new changes I am making to my posts not related to theme are not reflecting in chrome browser. For example for this post I added recipe index but in Chrome mobile browser it still shows old version.

@foodaholick Hi,

The problem with the date still showing in the slider happens probably because you have commented out incorrectly those lines.

Try to delete the lines from code completely or hide those details by adding this CSS code in the Customizer > Additional CSS instead:

.slides li .cat-links,
.slides li .entry-meta { display: none; }


Finally issue is resolved. Problem was my bluehost server cache. I thought I had cleared it but when I contacted customer support today, they told only they can clear the cache at their end since it’s a shared server. They have turned off the server cache for future.